【iOSアプリ開発 / CocoaPods】ライブラリのインストールでエラー「Specs satisfying the `ライブラリ名` dependency were found, but they required a higher minimum deployment target」が出る時の対処法

CocoaPodsでライブラリをインストールやアップデートした時に、以下のようなエラーが出る場合の対処法を紹介します。

Specs satisfying the `ライブラリ名` dependency were found, but they required a higher minimum deployment target

どういった場合に出るの?原因は?

pod install / pod updateを実行した時。

ライブラリは存在するが、ターゲットとなるiOSのバージョンが古い(対応していない)場合に発生する。

対応方法

ターゲットとなるiOSのバージョンを上げる。

platform :ios, '9.0' // 変更前
platform :ios, '10.0'  // 変更後

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA